基本描述

app开发常出现检测版本升级,需要提供操作界面需求,对于没有原生开发经验的童鞋来说,会存在以下问题:

.现没有能覆盖原生组件的插件,如果用popup等组件,如果存在原生title栏的,会发现不能完全覆盖

本插件仅适用于app开发,小程序直接通过发布审核升级,h5只需要发布新的网页。

安卓:点升级后,在程序内下载完成提示进行安装

苹果:点升级后,会跳转的苹果应用商店进行升级

v1.0.2 版本说明:

=============================

(1)修复升级包在下载中的情况,如果再次点击更新会重复下载问题
(2)新增进度读条显示模式
(3)新增支持跳转浏览器下载

=============================

v1.0.1 版本说明:

=============================

(1)优化部分元素渲染频率,提高性能
(2)修复部分情况下下载完成后不能安装问题

=============================

基本属性描述

属性名 类型 默认值 说明
packageUrl String '' 升级包下载地址
windowHeight Number 220 更新框高度
logo String /static/auto_updater.png logo图片(50x50)
content String '' 更新内容(\n可以强制换行)
contentAlign String left 内容位置(left,center,right)
loadingColor String #ff6666 下载进度颜色
cancel String 取消 取消按钮文本
cancelColor String #000000 取消按钮文本颜色
confirm String 升级 确认按钮文本
confirmColor String #ff6666 确认按钮文本颜色
browser Boolean false 是否浏览器下载

基本方法描述

方法名 方法参数 默认值 说明
init Object {} 初始化
show 显示
close 关闭

隐私、权限及商业化声明

1. 本插件需要申请的手机端权限列表:

安卓8.0以上的机型需加入权限:<uses-permission android:name="android.permission.REQUEST_INSTALL_PACKAGES"/>

2. 本插件采集的手机端数据、发送的服务器地址、以及数据用途说明:

3. 本插件是否包含广告,如包含需详细说明广告表达方式、展示频率:

使用中有什么不明白的地方,就向插件作者提问吧~ 我要提问